re = /(?P<date>[^":]+):(?P<price>[^":]+)/m
str = '["March:59", "April:64", "May:62"]
["Jan:55"]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end