#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{1,50}$)[a-z0-9]+(?:[-_\/][a-z0-9]+)*[-_\/]?$"
Local $sString = "hello" & @CRLF & _
"123hello" & @CRLF & _
"hello/world" & @CRLF & _
"hello_world" & @CRLF & _
"hello-world" & @CRLF & _
"hello-world/apple" & @CRLF & _
"hello_world/apple" & @CRLF & _
"hello_world/apple123" & @CRLF & _
"" & @CRLF & _
"helloWorld" & @CRLF & _
"-hello" & @CRLF & _
"_hello" & @CRLF & _
"$hello" & @CRLF & _
"/hello" & @CRLF & _
"hello$" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"hello_world/-apple" & @CRLF & _
"hello_world/_apple" & @CRLF & _
"hello_world//apple" & @CRLF & _
"" & @CRLF & _
"hello_" & @CRLF & _
"hello-" & @CRLF & _
"hello/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")