re = /^(?=.{1,50}$)[a-z0-9]+(?:[-_\/][a-z0-9]+)*[-_\/]?$/m
str = 'hello
123hello
hello/world
hello_world
hello-world
hello-world/apple
hello_world/apple
hello_world/apple123
helloWorld
-hello
_hello
$hello
/hello
hello$
hello_world/-apple
hello_world/_apple
hello_world//apple
hello_
hello-
hello/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end