const regex = /^(?=.{1,50}$)[a-z0-9]+(?:[-_\/][a-z0-9]+)*[-_\/]?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{1,50}$)[a-z0-9]+(?:[-_\\\/][a-z0-9]+)*[-_\\\/]?$', 'gm')
const str = `hello
123hello
hello/world
hello_world
hello-world
hello-world/apple
hello_world/apple
hello_world/apple123
helloWorld
-hello
_hello
\$hello
/hello
hello\$
hello_world/-apple
hello_world/_apple
hello_world//apple
hello_
hello-
hello/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}