import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{1,50}$)[a-z0-9]+(?:[-_\\/][a-z0-9]+)*[-_\\/]?$";
final String string = "hello\n"
+ "123hello\n"
+ "hello/world\n"
+ "hello_world\n"
+ "hello-world\n"
+ "hello-world/apple\n"
+ "hello_world/apple\n"
+ "hello_world/apple123\n\n"
+ "helloWorld\n"
+ "-hello\n"
+ "_hello\n"
+ "$hello\n"
+ "/hello\n"
+ "hello$\n\n\n"
+ "hello_world/-apple\n"
+ "hello_world/_apple\n"
+ "hello_world//apple\n\n"
+ "hello_\n"
+ "hello-\n"
+ "hello/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}