#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^[^:]*((array|unassigned)*)[^:]*\n$"
Local $sString = """"" & @CRLF & _
"Smart Array P822 in Slot 2" & @CRLF & _
" array A" & @CRLF & _
" array B" & @CRLF & _
" array C" & @CRLF & _
" SmartCache array D" & @CRLF & _
" Drive Authentication Status: Not Authenticated. Smart Array will not control drive LEDs." & @CRLF & _
" array E" & @CRLF & _
" unassigned" & @CRLF & _
""""" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")