import re
regex = re.compile(r"^[^:]*((array|unassigned)*)[^:]*\n$", flags=re.IGNORECASE)
test_str = ("\"\"\"\n"
"Smart Array P822 in Slot 2\n"
" array A\n"
" array B\n"
" array C\n"
" SmartCache array D\n"
" Drive Authentication Status: Not Authenticated. Smart Array will not control drive LEDs.\n"
" array E\n"
" unassigned\n"
"\"\"\"\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")