re = /^[^:]*((array|unassigned)*)[^:]*\n$/i
str = '"""
Smart Array P822 in Slot 2
array A
array B
array C
SmartCache array D
Drive Authentication Status: Not Authenticated. Smart Array will not control drive LEDs.
array E
unassigned
"""
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end