using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\d\s].+(?:[A-Z\s]*)*$";
string input = @"Here goes some text. {tag} A wonderful day. It's soon cristmas.
2 Happy 2019, soon. {Some useful tag!} Something else goes here.
3 Happy ending. Yeppe! See you.
4
5 Happy KKK!
6 Happy B-Day!
7
8 Universe is cool!
9
10 {Tagish}.
11
12 {Slugish}. Here goes another line. {Slugish} since this is a new sentence.
13
14 endline.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}