// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\d\s].+(?:[A-Z\s]*)*$").unwrap();
let string = "Here goes some text. {tag} A wonderful day. It's soon cristmas.
2 Happy 2019, soon. {Some useful tag!} Something else goes here.
3 Happy ending. Yeppe! See you.
4
5 Happy KKK!
6 Happy B-Day!
7
8 Universe is cool!
9
10 {Tagish}.
11
12 {Slugish}. Here goes another line. {Slugish} since this is a new sentence.
13
14 endline.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}