# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r'^[\d\s].+(?:[A-Z\s]*)*$'
test_str = ("Here goes some text. {tag} A wonderful day. It's soon cristmas.\n"
"2 Happy 2019, soon. {Some useful tag!} Something else goes here.\n"
"3 Happy ending. Yeppe! See you.\n"
"4\n"
"5 Happy KKK!\n"
"6 Happy B-Day!\n"
"7\n"
"8 Universe is cool!\n"
"9\n"
"10 {Tagish}.\n"
"11\n"
"12 {Slugish}. Here goes another line. {Slugish} since this is a new sentence.\n"
"13\n"
"14 endline.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur'' to prefix the regex and u"" to prefix the test string and substitution.