use strict;
my $str = 'Here goes some text. {tag} A wonderful day. It\'s soon cristmas.
2 Happy 2019, soon. {Some useful tag!} Something else goes here.
3 Happy ending. Yeppe! See you.
4
5 Happy KKK!
6 Happy B-Day!
7
8 Universe is cool!
9
10 {Tagish}.
11
12 {Slugish}. Here goes another line. {Slugish} since this is a new sentence.
13
14 endline.';
my $regex = qr/^[\d\s].+(?:[A-Z\s]*)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}