using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""catched"">(?s)(.+?)</div>";
string input = @"<div class=""catched"">
something maybe with divs and more
</div>
<div class=""catched"">
something else
</div>
<div class=""catched"">
something else
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}