$re = '~<div class="catched">(?s)(.+?)</div>~m';
$str = '<div class="catched">
something maybe with divs and more
</div>
<div class="catched">
something else
</div>
<div class="catched">
something else
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);