// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<div class="catched">(?s)(.+?)</div>"#).unwrap();
let string = "<div class=\"catched\">
something maybe with divs and more
</div>
<div class=\"catched\">
something else
</div>
<div class=\"catched\">
something else
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}