package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<div class="catched">(?s)(.+?)</div>`)
var str = `<div class="catched">
something maybe with divs and more
</div>
<div class="catched">
something else
</div>
<div class="catched">
something else
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}