import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div\\s+?(.*?)\\s+?(id|class)\\s*?=\\s*?\"(.+?)\"\\s+(.*)\\s*?>";
final String string = "<div style = \"border: 1px\" id = \"header\" >\n"
+ "<div align=\"left\" id=\"nav\" style=\"color:blue\">\n"
+ "<div class=\"header\" style=\"color:blue\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}