import re
regex = re.compile(r"<div\s+?(.*?)\s+?(id|class)\s*?=\s*?\"(.+?)\"\s+(.*)\s*?>", flags=re.MULTILINE)
test_str = ("<div style = \"border: 1px\" id = \"header\" >\n"
"<div align=\"left\" id=\"nav\" style=\"color:blue\">\n"
"<div class=\"header\" style=\"color:blue\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")