#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)a(bb)"
Local $sString = "aabbabbabbaaa" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"expectedoutput" & @CRLF & _
"Start :1, End : 4, Group abb" & @CRLF & _
"Start :4, End : 7, Group abb" & @CRLF & _
"Start :7, End : 10,Group abb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")