use strict;
my $str = 'aabbabbabbaaa
expectedoutput
Start :1, End : 4, Group abb
Start :4, End : 7, Group abb
Start :7, End : 10,Group abb';
my $regex = qr/a(bb)/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}