re = /a(bb)/i
str = 'aabbabbabbaaa
expectedoutput
Start :1, End : 4, Group abb
Start :4, End : 7, Group abb
Start :7, End : 10,Group abb'
# Print the match result
str.match(re) do |match|
puts match.to_s
end