package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{4}(?:[,:]\d{4})*$`)
var str = `1000
1200
1000:1200
1000,1200
1010:1015,1019,1025:1027
1000,1200,1100
1000:1001:1002
1000,1200,1100,
1201
999
,1111
:1111
:1111,
,1111:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}