// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{4}(?:[,:]\d{4})*$").unwrap();
let string = "1000
1200
1000:1200
1000,1200
1010:1015,1019,1025:1027
1000,1200,1100
1000:1001:1002
1000,1200,1100,
1201
999
,1111
:1111
:1111,
,1111:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}