re = /^\d{4}(?:[,:]\d{4})*$/m
str = '1000
1200
1000:1200
1000,1200
1010:1015,1019,1025:1027
1000,1200,1100
1000:1001:1002
1000,1200,1100,
1201
999
,1111
:1111
:1111,
,1111:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end