use strict;
my $str = 'Lorem ipsum ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Mauris ultrices eros in cursus turpis massa tincidunt. Ipsum a arcu cursus vitae congue. Lobortis mattis aliquam faucibus purus in massa. Pellentesque id nibh tortor id aliquet lectus proin nibh. Ultrices tincidunt arcu arcu non sodales neque sodales ut etiam. Enim praesent elementum facilisis leo vel fringilla. Sapien eget mi proin sed. Gravida arcu ac tortor dignissim convallis aenean et tortor at. Tortor consequat id porta nibh nibh venenatis. Tincidunt augue interdum velit euismod in pellentesque massa placerat. Pretium aenean pharetra magna ac placerat vestibulum. Fermentum posuere urna urna nec tincidunt praesent semper feugiat nibh. Sagittis aliquam malesuada bibendum arcu vitae elementum curabitur. Bibendum ut tristique et egestas quis ipsum suspendisse ultrices. Consectetur purus ut faucibus pulvinar elementum integer enim. Elementum nisi quis eleifend quam adipiscing vitae proin sagittis.';
my $regex = qr/\b(\w+)\s\1\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}