$re = '/\b(\w+)\s\1\b/m';
$str = 'Lorem ipsum ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Mauris ultrices eros in cursus turpis massa tincidunt. Ipsum a arcu cursus vitae congue. Lobortis mattis aliquam faucibus purus in massa. Pellentesque id nibh tortor id aliquet lectus proin nibh. Ultrices tincidunt arcu arcu non sodales neque sodales ut etiam. Enim praesent elementum facilisis leo vel fringilla. Sapien eget mi proin sed. Gravida arcu ac tortor dignissim convallis aenean et tortor at. Tortor consequat id porta nibh nibh venenatis. Tincidunt augue interdum velit euismod in pellentesque massa placerat. Pretium aenean pharetra magna ac placerat vestibulum. Fermentum posuere urna urna nec tincidunt praesent semper feugiat nibh. Sagittis aliquam malesuada bibendum arcu vitae elementum curabitur. Bibendum ut tristique et egestas quis ipsum suspendisse ultrices. Consectetur purus ut faucibus pulvinar elementum integer enim. Elementum nisi quis eleifend quam adipiscing vitae proin sagittis.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);