# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(\w+)\s\1\b"
test_str = "Lorem ipsum ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Mauris ultrices eros in cursus turpis massa tincidunt. Ipsum a arcu cursus vitae congue. Lobortis mattis aliquam faucibus purus in massa. Pellentesque id nibh tortor id aliquet lectus proin nibh. Ultrices tincidunt arcu arcu non sodales neque sodales ut etiam. Enim praesent elementum facilisis leo vel fringilla. Sapien eget mi proin sed. Gravida arcu ac tortor dignissim convallis aenean et tortor at. Tortor consequat id porta nibh nibh venenatis. Tincidunt augue interdum velit euismod in pellentesque massa placerat. Pretium aenean pharetra magna ac placerat vestibulum. Fermentum posuere urna urna nec tincidunt praesent semper feugiat nibh. Sagittis aliquam malesuada bibendum arcu vitae elementum curabitur. Bibendum ut tristique et egestas quis ipsum suspendisse ultrices. Consectetur purus ut faucibus pulvinar elementum integer enim. Elementum nisi quis eleifend quam adipiscing vitae proin sagittis."
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.