use strict;
my $str = 'tabtab';
my $regex = qr/tab/mp;
my $subst = '\\t';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";