# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<="(?:phone|email)":")[^"]+(?=")|[^@"\s]+@[^@"\s]+/*****/gm;t' <<< "\"email\":\"testEmail@test.com\", \"phone\":\"1111111111\", \"text\":\"sample text may contain email testEmail@test.com as well\"
"