#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<="(?:phone|email)":")[^"]+(?=")|[^@"\s]+@[^@"\s]+"
Local $sString = ""email":"testEmail@test.com", "phone":"1111111111", "text":"sample text may contain email testEmail@test.com as well"" & @CRLF & _
""
Local $sSubst = "*****"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)