import Foundation
let pattern = #"(?<="(?:phone|email)":")[^"]+(?=")|[^@"\s]+@[^@"\s]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"email":"testEmail@test.com", "phone":"1111111111", "text":"sample text may contain email testEmail@test.com as well"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*****"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)