import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\"(?:phone|email)\":\")[^\"]+(?=\")|[^@\"\\s]+@[^@\"\\s]+";
final String string = "\"email\":\"testEmail@test.com\", \"phone\":\"1111111111\", \"text\":\"sample text may contain email testEmail@test.com as well\"\n";
final String subst = "*****";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}