#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bif\s*([^:]+):\s+([^:]+)\s+(?::else:\s+([^:]+)\s+)?endif\b"
Local $sString = "Text if(stat(fire) ): x :else: w endif" & @CRLF & _
" if o: s endif; " & @CRLF & _
" if is_night(): die(); horribly(); :else: live() endif" & @CRLF & _
"" & @CRLF & _
"attack(5); if attack_was_lethal(): heal(1); gain(block, get_stat(strength)); :else: heal(-1) endif; draw(1)" & @CRLF & _
"" & @CRLF & _
"if multiline():" & @CRLF & _
" abc" & @CRLF & _
":else:" & @CRLF & _
" def" & @CRLF & _
"endif"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")