using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bif\s*([^:]+):\s+([^:]+)\s+(?::else:\s+([^:]+)\s+)?endif\b";
string input = @"Text if(stat(fire) ): x :else: w endif
if o: s endif;
if is_night(): die(); horribly(); :else: live() endif
attack(5); if attack_was_lethal(): heal(1); gain(block, get_stat(strength)); :else: heal(-1) endif; draw(1)
if multiline():
abc
:else:
def
endif";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}