use strict;
my $str = 'Text if(stat(fire) ): x :else: w endif
if o: s endif;
if is_night(): die(); horribly(); :else: live() endif
attack(5); if attack_was_lethal(): heal(1); gain(block, get_stat(strength)); :else: heal(-1) endif; draw(1)
if multiline():
abc
:else:
def
endif';
my $regex = qr/\bif\s*([^:]+):\s+([^:]+)\s+(?::else:\s+([^:]+)\s+)?endif\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}