import Foundation
let pattern = #"\bif\s*([^:]+):\s+([^:]+)\s+(?::else:\s+([^:]+)\s+)?endif\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Text if(stat(fire) ): x :else: w endif
if o: s endif;
if is_night(): die(); horribly(); :else: live() endif
attack(5); if attack_was_lethal(): heal(1); gain(block, get_stat(strength)); :else: heal(-1) endif; draw(1)
if multiline():
abc
:else:
def
endif
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)