#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)(?:"?([^"]*)"?\s)?(?:<?(.+@[^>]+)>?)"
Local $sString = "test@domain.com" & @CRLF & _
"test user <test@domain.com>" & @CRLF & _
"test user<test@domain.com>" & @CRLF & _
""test user" <test@domain.com>" & @CRLF & _
""test user"<test@domain.com>" & @CRLF & _
""test user"again<test@domain.com>" & @CRLF & _
""test user" <test@domain.com" & @CRLF & _
""test user" test@domain.com>" & @CRLF & _
"test user <test@domain.com" & @CRLF & _
"test user test@domain.com>" & @CRLF & _
""test user <test@domain.com>" & @CRLF & _
"test user" <test@domain.com>" & @CRLF & _
""test user" test@domain.com" & @CRLF & _
""test"user <test@domain.com>" & @CRLF & _
"t"es"t@domain.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")