re = /(?:"?([^"]*)"?\s)?(?:<?(.+@[^>]+)>?)/mix
str = 'test@domain.com
test user <test@domain.com>
test user<test@domain.com>
"test user" <test@domain.com>
"test user"<test@domain.com>
"test user"again<test@domain.com>
"test user" <test@domain.com
"test user" test@domain.com>
test user <test@domain.com
test user test@domain.com>
"test user <test@domain.com>
test user" <test@domain.com>
"test user" test@domain.com
"test"user <test@domain.com>
t"es"t@domain.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end