$re = '/(?:"?([^"]*)"?\s)?(?:<?(.+@[^>]+)>?)/mix';
$str = 'test@domain.com
test user <test@domain.com>
test user<test@domain.com>
"test user" <test@domain.com>
"test user"<test@domain.com>
"test user"again<test@domain.com>
"test user" <test@domain.com
"test user" test@domain.com>
test user <test@domain.com
test user test@domain.com>
"test user <test@domain.com>
test user" <test@domain.com>
"test user" test@domain.com
"test"user <test@domain.com>
t"es"t@domain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);