using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""?([^""]*)""?\s)?(?:<?(.+@[^>]+)>?)";
string input = @"test@domain.com
test user <test@domain.com>
test user<test@domain.com>
""test user"" <test@domain.com>
""test user""<test@domain.com>
""test user""again<test@domain.com>
""test user"" <test@domain.com
""test user"" test@domain.com>
test user <test@domain.com
test user test@domain.com>
""test user <test@domain.com>
test user"" <test@domain.com>
""test user"" test@domain.com
""test""user <test@domain.com>
t""es""t@domain.com";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}