#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\.](".*)?[^\s@]+(.*")?[^\.]?@[^-][^\s@]+\.[^\s@]+$"
Local $sString = "david.b@o-m.com" & @CRLF & _
"email@domain.com" & @CRLF & _
"firstname.lastname@domain.com" & @CRLF & _
"email@subdomain.domain.com" & @CRLF & _
"firstname+lastname@domain.com" & @CRLF & _
"email@123.123.123.123" & @CRLF & _
"email@[123.123.123.123]" & @CRLF & _
""email"@domain.com" & @CRLF & _
"1234567890@domain.com" & @CRLF & _
"email@domain-one.com" & @CRLF & _
"_______@domain.com" & @CRLF & _
"email@domain.name" & @CRLF & _
"email@domain.co.jp" & @CRLF & _
"firstname-lastname@domain.com" & @CRLF & _
"Abc@example.com" & @CRLF & _
"Abc.123@example.com" & @CRLF & _
"user+mailbox/department=shipping@example.com" & @CRLF & _
"!#$%&'*+-/=?^_`.{|}~@example.com" & @CRLF & _
""Abc@def"@example.com" & @CRLF & _
""Fred Bloggs"@example.com" & @CRLF & _
""Joe.\\Blow"@example.com" & @CRLF & _
"用户@例子.广告" & @CRLF & _
"अजय@डाटा.भारत" & @CRLF & _
"квіточка@пошта.укр" & @CRLF & _
"θσερ@εχαμπλε.ψομ" & @CRLF & _
"Dörte@Sörensen.example.com" & @CRLF & _
"аджай@экзампл.рус" & @CRLF & _
"伊昭傑@郵件.商務" & @CRLF & _
"ाम@मोहन.ईन्फो" & @CRLF & _
"юзер@екзампл.ком" & @CRLF & _
"θσερ@εχαμπλε.ψομ" & @CRLF & _
"JosễSilvễ@googlễ.com" & @CRLF & _
"JosễSilvễ@google.com" & @CRLF & _
"JosễSilva@google.com" & @CRLF & _
"FoO@BaR.CoM" & @CRLF & _
"john@192.168.10.100" & @CRLF & _
"gómez@junk.br" & @CRLF & _
"Abc@example.com" & @CRLF & _
"Abc.123@example.com" & @CRLF & _
"user+mailbox/department=shipping@example.com" & @CRLF & _
"!#$%&'*+-/=?^_`.{|}~@example.com" & @CRLF & _
""Fred\ Bloggs"@example.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"plainaddress" & @CRLF & _
"""@example.com" & @CRLF & _
"Abc@def@example.com" & @CRLF & _
"Fred Bloggs@example.com" & @CRLF & _
"#@%^%#$@#$@#.com" & @CRLF & _
"@domain.com" & @CRLF & _
"Joe Smith <email@domain.com>" & @CRLF & _
"email.domain.com" & @CRLF & _
"email@domain@domain.com" & @CRLF & _
".email@domain.com" & @CRLF & _
"email.@domain.com" & @CRLF & _
"email..email@domain.com" & @CRLF & _
"email@domain.com (Joe Smith)" & @CRLF & _
"email@domain" & @CRLF & _
"email@-domain.com" & @CRLF & _
"email@111.222.333.44444" & @CRLF & _
"email@domain..com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")