package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\.](".*)?[^\s@]+(.*")?[^\.]?@[^-][^\s@]+\.[^\s@]+$`)
var str = `david.b@o-m.com
email@domain.com
firstname.lastname@domain.com
email@subdomain.domain.com
firstname+lastname@domain.com
email@123.123.123.123
email@[123.123.123.123]
"email"@domain.com
1234567890@domain.com
email@domain-one.com
_______@domain.com
email@domain.name
email@domain.co.jp
firstname-lastname@domain.com
Abc@example.com
Abc.123@example.com
user+mailbox/department=shipping@example.com
!#$%&'*+-/=?^_\`.{|}~@example.com
"Abc@def"@example.com
"Fred Bloggs"@example.com
"Joe.\\Blow"@example.com
用户@例子.广告
अजय@डाटा.भारत
квіточка@пошта.укр
θσερ@εχαμπλε.ψομ
Dörte@Sörensen.example.com
аджай@экзампл.рус
伊昭傑@郵件.商務
ाम@मोहन.ईन्फो
юзер@екзампл.ком
θσερ@εχαμπλε.ψομ
JosễSilvễ@googlễ.com
JosễSilvễ@google.com
JosễSilva@google.com
FoO@BaR.CoM
john@192.168.10.100
gómez@junk.br
Abc@example.com
Abc.123@example.com
user+mailbox/department=shipping@example.com
!#$%&'*+-/=?^_\`.{|}~@example.com
"Fred\ Bloggs"@example.com
plainaddress
""@example.com
Abc@def@example.com
Fred Bloggs@example.com
#@%^%#$@#$@#.com
@domain.com
Joe Smith <email@domain.com>
email.domain.com
email@domain@domain.com
.email@domain.com
email.@domain.com
email..email@domain.com
email@domain.com (Joe Smith)
email@domain
email@-domain.com
email@111.222.333.44444
email@domain..com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}