# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\.](\".*)?[^\s@]+(.*\")?[^\.]?@[^-][^\s@]+\.[^\s@]+$"
test_str = ("david.b@o-m.com\n"
"email@domain.com\n"
"firstname.lastname@domain.com\n"
"email@subdomain.domain.com\n"
"firstname+lastname@domain.com\n"
"email@123.123.123.123\n"
"email@[123.123.123.123]\n"
"\"email\"@domain.com\n"
"1234567890@domain.com\n"
"email@domain-one.com\n"
"_______@domain.com\n"
"email@domain.name\n"
"email@domain.co.jp\n"
"firstname-lastname@domain.com\n"
"Abc@example.com\n"
"Abc.123@example.com\n"
"user+mailbox/department=shipping@example.com\n"
"!#$%&'*+-/=?^_`.{|}~@example.com\n"
"\"Abc@def\"@example.com\n"
"\"Fred Bloggs\"@example.com\n"
"\"Joe.\\\\Blow\"@example.com\n"
"用户@例子.广告\n"
"अजय@डाटा.भारत\n"
"квіточка@пошта.укр\n"
"θσερ@εχαμπλε.ψομ\n"
"Dörte@Sörensen.example.com\n"
"аджай@экзампл.рус\n"
"伊昭傑@郵件.商務\n"
"ाम@मोहन.ईन्फो\n"
"юзер@екзампл.ком\n"
"θσερ@εχαμπλε.ψομ\n"
"JosễSilvễ@googlễ.com\n"
"JosễSilvễ@google.com\n"
"JosễSilva@google.com\n"
"FoO@BaR.CoM\n"
"john@192.168.10.100\n"
"gómez@junk.br\n"
"Abc@example.com\n"
"Abc.123@example.com\n"
"user+mailbox/department=shipping@example.com\n"
"!#$%&'*+-/=?^_`.{|}~@example.com\n"
"\"Fred\\ Bloggs\"@example.com\n\n\n"
"plainaddress\n"
"\"\"@example.com\n"
"Abc@def@example.com\n"
"Fred Bloggs@example.com\n"
"#@%^%#$@#$@#.com\n"
"@domain.com\n"
"Joe Smith <email@domain.com>\n"
"email.domain.com\n"
"email@domain@domain.com\n"
".email@domain.com\n"
"email.@domain.com\n"
"email..email@domain.com\n"
"email@domain.com (Joe Smith)\n"
"email@domain\n"
"email@-domain.com\n"
"email@111.222.333.44444\n"
"email@domain..com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.