import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<![-#/])literal(?!</a>)\\b";
final String string = "<p>Literal in computer science is a\n"
+ "<a href='http://www.google.com/something/literal#literal'>literal</a>\n"
+ "for representing a fixed value in source code. Almost all programming \n"
+ "<a href='http://www.google.com/something/else-literal#literal'>languages</a>\n"
+ "have notations for atomic values such as integers, floating-point \n"
+ "numbers, and strings, and usually for booleans and characters; some\n"
+ "also have notations for elements of enumerated types and compound\n"
+ "values such as arrays, records, and objects. An anonymous function\n"
+ "is a literal for the function type which is LITERAL</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}