$re = '~\b(?<![-#/])literal(?!</a>)\b~i';
$str = '<p>Literal in computer science is a
<a href=\'http://www.google.com/something/literal#literal\'>literal</a>
for representing a fixed value in source code. Almost all programming
<a href=\'http://www.google.com/something/else-literal#literal\'>languages</a>
have notations for atomic values such as integers, floating-point
numbers, and strings, and usually for booleans and characters; some
also have notations for elements of enumerated types and compound
values such as arrays, records, and objects. An anonymous function
is a literal for the function type which is LITERAL</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);