#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(?i)(http|https|ftp):\/\/(\S+)"
Local $sString = "Sample with with your example https://website.com/bestsellers/someotherinfo and then with query parameters" & @CRLF & _
"https://website.com/bestsellers/someotherinfo?query1&q2 " & @CRLF & _
"and some other URLs<br></br>https://xyz.com/index.html some text after http://www.ex.com/test.html there are still more text as like ftp://ftp.test.com/ , which is also matching" & @CRLF & _
"and finally a URL that is really NOT fully formed:" & @CRLF & _
"https://a so you might test for the CG #2."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")