const regex = /(?i)(http|https|ftp):\/\/(\S+)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(http|https|ftp):\\\/\\\/(\\S+)', 'gu')
const str = `Sample with with your example https://website.com/bestsellers/someotherinfo and then with query parameters
https://website.com/bestsellers/someotherinfo?query1&q2
and some other URLs<br></br>https://xyz.com/index.html some text after http://www.ex.com/test.html there are still more text as like ftp://ftp.test.com/ , which is also matching
and finally a URL that is really NOT fully formed:
https://a so you might test for the CG #2.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}