re = /(?i)(http|https|ftp):\/\/(\S+)/
str = 'Sample with with your example https://website.com/bestsellers/someotherinfo and then with query parameters
https://website.com/bestsellers/someotherinfo?query1&q2
and some other URLs<br></br>https://xyz.com/index.html some text after http://www.ex.com/test.html there are still more text as like ftp://ftp.test.com/ , which is also matching
and finally a URL that is really NOT fully formed:
https://a so you might test for the CG #2.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end