use strict;
my $str = 'Sample with with your example https://website.com/bestsellers/someotherinfo and then with query parameters
https://website.com/bestsellers/someotherinfo?query1&q2
and some other URLs<br></br>https://xyz.com/index.html some text after http://www.ex.com/test.html there are still more text as like ftp://ftp.test.com/ , which is also matching
and finally a URL that is really NOT fully formed:
https://a so you might test for the CG #2.';
my $regex = qr/(?i)(http|https|ftp):\/\/(\S+)/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}