package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(([\d]{9}[13579]\d [a-z]+ski)|([\d]{9}[02468]\d [a-z]+ska))$`)
var str = `96112103648 kowalska
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}